Vyšla nová verze WordPress 5.0

Dne 6. 12. 2018 vyšla nová verze WordPress 5.0, která sebou přinesla obávaný page builder s názvem Gutenberg a možná rozhodila funkčnost několika webů. Tento editor nahradil ten stávající TinyMCE.

Nová aktualizace vám může způsobit špatné zobrazení obsahu na vašem webu, protože Gutenberg je nekompatibilní se spousty pluginy a page buildery. Například některé pluginy jako WPML vůbec nedoporučují aktualizaci, protože nemohou zaručit kompatibilitu.


Pokud si nevíte rady a nechcete si web aktualizovat sami, najměte si odborníky nebo si můžete u nás objednat pravidelnou správu webových stránek.


Náš web www.freshmill.cz už na nové verzi jede a musíme konstatovat, že vše funguje tak, jak má. S editorem se nám při psaní tohoto článku pracovalo velmi dobře. Objevili jsme spousty nových funkcí. Vše se nám zdá přehledné a vítáme chytré vyhledávání u kolonky „Add block“. Texty si můžeme různě prohazovat a trochu nám to připomíná editor, který známe z kreativního portálu Behance.net. Texty v Gutenbergu přidáváte pomocí bloků, takže je to úplně něco jiného než u klasického editoru.

Z našeho pohledu je to určitě velká změna se kterou půjde vytvářet mnohem propracovanější webové stránky, ale vývoj na sobě bude muset pořádně zamakat, aby se vyrovnal ověřeným builderům jako jsou například Elementor, Divi, Muffin Builder. Na druhou stranu TinyMCE je starý a neodpovídá dnešní době. Klasický editor už používat nechceme.

S novým editorem má uživatel pod kontrolou responzivní verzi, protože jednotlivé bloky jsou už optimalizované pro mobilní telefony. To u TinyMCE byl problém. Velkou výhodou Gutenbergu je také page builder se kterým lze jednotlivé obsahové bloky mezi sebou prohazovat.

Jak to vidíme my?

Aktualizaci nevidíme zase tak tragicky, jak se někteří obávají. Je to změna a ten, kdo se o svůj web stará, tak překvapený nebude. Ostatním se možná zhroutí svět, protože při jakýchkoliv problémech si budou muset najmout odborníka, který jim web dá dohromady. Doporučujeme si proto před aktualizaci na novou verzi web zazálohovat nebo oslovit odborníka.

Mnoho uživatelů WordPressu má na TinyMCE postavené nějaké řešení a s aktualizací je množné, že vám toto přestane fungovat. Možným řešením je vůbec WordPress neaktualizovat nebo si najmout zkušené vývojaře, kteří web na Gutenberg přizpůsobí.

Rozhodně, ale nedoporučujeme web neaktiualizovat. Nové verze vždy zalepují díry a vylepšují bezpečnost celého systému. Když prostě nebudete chtít používat nový editor a chete používat ten původní, stačí si nainstalovat plugin Classic Editor. Ten bude podporován až do roku 2021.

© 2014 – 2018 – Kopírování obsahu je zakázáno Fresh Mill

Web vytvořilo digitální studio Fresh Mill